Battlezone 1

Community Forum
Home Page * Home Page Home Page
  Register
Login 

Delete all board cookies


Contact Us | All times are UTC



Welcome
Welcome to Battlezone 1 Forum!

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. Registration is fast, simple, and absolutely free, so please, join our community today!


Home Page Home Page  [ 4 posts ] 
  Print view
Previous topic | Next topic 
Author Message
Offline 
 Post subject: Overcoming Vista 64Bit Hurtles! Unhandled Exception!
PostPosted: May 21st, 2008, 7:11 am 

Joined: May 21st, 2008, 6:54 am
Posts: 54
Hi all!

First off I'm very excited about this, found 1.4M on piratebay, and there was a comment directing people here for more information. Needless to say I used to play Battlezone, addictively. It is my favorite game and I'm very excited 1.4M is around, and in fact I didn't even realize it till something forced me to search for battlezone!

Anyways, I am wanting to play this game on my Windows Vista Ultima 64bit system. When I initially tried to launch the game I got this error message:

Quote:
This application has failed to start because MSVCP50.dll was not found.
Reinstalling the application may fix this problem.


Obviously I reinstalled the application, but that didn't seem to fix the problem, so I did a little research and located the DLL file here. Which took care of that problem. I placed the file in the Battlezone Directory.

----------------------------
Problem #2 - Not enough memory.
----------------------------
After supplying the game with the MSVCP50.dll file, I attempted to launch the game again, and received the following error message:

Quote:
Sorry, there is not enough memory to continue.
Please make sure that you have at least 50MB free on your hard drive
and that virtual memory is not disabled."


I actually managed to fix this by enabling compatibility mode for the executable, which I forgot to do in th efirst place after reinstalling.

---------------------------
Problem #3 - Unhandled Exception on launch
---------------------------
When I launch the game now, I get the Unhandled Exception error. So far I have not been able to fix it while fiddling around with all of the computability options.

Advice on this is greatly needed.


Top
 Profile  
 
 
Offline 
 Post subject:
PostPosted: May 21st, 2008, 11:35 am 
senior member

Joined: August 20th, 2007, 12:17 pm
Posts: 3465
Location: Zagreb, Croatia
Hi DarkOddity,

Thank you for such a comprehensive post. It will help newcomers if they get stuck on problem #1 or problem #2, but of course, only if we find solution for problem #3. :)

Do you have SP1? That might help.
Do you use BZ CD or you are using BZ image? If you are using CD, BZ will try to run intro movie but it won't be able due to missing codec in Vista.
You can also turn intro OFF with Config Utility or add "/nointro" in your BZ shortcut target line.

FURION wrote:
I've been trying to run BZ on Vista to no avail, it gives me a UE when just before I can jump into a game by myself and when I enter a games chat when someone is there it never lets me join.


Tuffkix wrote:
Hey, I got vista ultimate, and when I try to run bz, i get a ue


navbeacon wrote:
It works fine for me on Vista 64-bit.


but he also said

navbeacon wrote:
Do NOT use compitability mode
Be sure to run program as an administrator.


that will get you back on problem #2... :?

Damn Vista, it seems that it works differently on different machines, because everybody is getting different errors. Some are even playing BZ on it, without a problems, so if they made it, we should make it too...

Seems you didn't have to turn UAC off, like this guy.

But you're getting UE...
On other OS's in 90% cases UE is a result of resolution mismatch, so try with that. Make sure that your game resolution matches your desktop resolution, or at least try various game resolution if you can't find a perfect match.

Also, check your render.cfg in BZ folder. If you installed BZ in default directory (C:\Program Files\Activision\Battlezone) use Configuration Utility from BZ start menu to open render. If you changed instalation folder Config Utility won't work, so then open render.cfg with notepad/wordpad. First try with Z-buffer (common BZ problem) on/off (remove semicolon " ; " and enter 0 for off, 1 for on), then start experimenting with other options there...

If everything fails, I suggest installing of Virtual PC and its service pack. Then you can mount Windows XP or 98 on it.
Dual system boot it's a little bit more complicated but it has the same purpose.

Unfortunately, BZ is old game and last official fix for it was made in '98 (XP patch for BZ came from another game). I guess we came pretty far on our own. :)
Now we are fighting with Vista and directX 10 cards, so many BZ fans are building 2nd computer, with XP and DirectX 9 card, just for BZ.

I understand that I probably didn't help you like you expected, but that info is all I got. I even searched other forums, but they don't know the answer either. I will keep monitoring BZ and Vista scene and I will post here as soon as something new is discovered.

Mr. Spock


Top
 Profile  
 
Offline 
 Post subject:
PostPosted: May 21st, 2008, 8:12 pm 

Joined: May 21st, 2008, 6:54 am
Posts: 54
Looks like this is going to become quite the pet project of mine... Fixing bz on Vista. I appreciate the information and links, all very valuable information.

As far as the UAC goes, it was turned off shortly after installing the operating system so I never encountered that problem.

As far as the resolution mismatch is concerned, I've tried running the program in windowed mode (I have a 1920x1200 native monitor on this Vista computer) to bypass matching my native.. I have no idea if the game even with all the patches, will run in this resolution (Though I'm hoping it will).

I also have a XP machine (Didn't want to mess with it but meh.) so I'm installing 1.4M and the 1.4M Expansion on it now to see how that works out, if I can atleast get it working on one of my two PC's, that will be enough.

---
Ok, I have it installed and running just fine on my XP machine. Now I just have to get it running on this one.

Ok nix that, it's running just fine aside from the fact that it seems to think my PC can't handle BZ... and is giving my severe FPS lag with more than 1 opponent on screen, and lockups if they are firing.


Top
 Profile  
 
Offline 
 Post subject:
PostPosted: May 22nd, 2008, 10:49 am 
senior member

Joined: August 20th, 2007, 12:17 pm
Posts: 3465
Location: Zagreb, Croatia
DarkOddyty wrote:
I've tried running the program in windowed mode


Window mode works only with 640x480.

grim8.0 wrote:
GeForce 6600
LCD DISPLAY 1240x768 or what ever it is. I am using the above graphix card. I have very low frame rate in comparison to my friends who have even older computers than I(custum built 2003 models compared to my 2004 or 5 custom built). I'm running XP(prefer lunix oh well) I have done the teak guide already. My big problem is, I'll start playing then my frame rate will go down from 20 to 5 after that the monitor freezes, but you can hear sound. The only way to avoid freezing up my screen completely is alt tabbing and minimizing the game. But I still end up with the game with a black screen and dieing on me exiting out and giving me the usless "Do you want to send an error report" screen.


He hasn't recieved help.

I think you both have graphic card problems... Try the newest driver or much older (a year or more) than you have now. Nvidia has a memory leak with textures on new drivers.
Also try this - DirectX End-User Runtimes (March 2008).

And can you please post your both computers specifications (processor, RAM, graphic card, OS+SP, display resolution, 3rd party firewall?) for future references.

Edit: old drivers links:
http://www.nvidia.com/object/winxp_2k_94.24_2.html
http://www.nvidia.com/object/winxp_2k_93.71_2.html
http://www.nvidia.com/object/winxp_163.75.html
http://www.nvidia.com/object/winxp_169.21_whql.html


Top
 Profile  
 
Display posts from previous:  Sort by  
Home Page Home Page  [ 4 posts ] 

Contact Us | All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Jump to:  

Donate Now
Donate Now


Powered by Skin-Lab © Alpha Trion
Hosted by © 2014 FreeForums.org | Create a free forum | Powered by phpBB
About FreeForums | Legal | Advertise Here | Investors | Contact FreeForums.org
suspicion-preferred